Utama Pc & Mac Apakah Email Peka Huruf Besar-kecil?

Apakah Email Peka Huruf Besar-kecil?



Ada banyak kebingungan mengenai apakah alamat email peka huruf besar-kecil atau tidak. Beberapa mengatakan mereka, sementara yang lain mengklaim bahwa mereka tidak. Jadi, siapa yang benar? Dalam artikel ini kita akan melihat apakah alamat email peka huruf besar atau kecil.

Apakah Email Peka Huruf Besar-kecil?

Apa yang Membuat Alamat Email?

Alamat email terdiri dari tiga bagian – bagian lokal (juga dikenal sebagai nama pengguna), tanda @, dan bagian domain. Setiap bagian memiliki perannya sendiri dan tunduk pada aturannya sendiri. Berikut ikhtisar singkatnya.

Menurut standar, bagian lokal dari alamat email dapat memiliki panjang hingga 64 karakter dan dapat terdiri dari kumpulan karakter yang terbatas. Ini termasuk huruf abjad Latin huruf besar dan kecil, angka dari 0 hingga 9, titik, dan karakter khusus. Karakter khusus termasuk ` [email protected] #$%^&*()_-+=[]{}~. Itu terhubung ke bagian domain dengan tanda @.

Bagian domain bisa sampai 255 karakter. Ini dapat berisi huruf alfabet Latin (huruf kecil dan besar), angka dari 0 hingga 9, dan tanda hubung. Tanda hubung tidak dapat memulai atau mengakhiri bagian domain.

Simbol internasional juga dapat digunakan, meskipun lebih lanjut tentang itu nanti.

Apakah Ini Peka Huruf Besar-kecil?

Jawaban yang benar untuk pertanyaan ini adalah ya dan tidak. Berdasarkan RFC 5321 , bagian lokal dari alamat email peka huruf besar/kecil. Artinya, secara teori, [email protected] tidak sama dengan [email protected] Namun, penyedia email memiliki kebebasan untuk memperlakukan bagian lokal sebagai case sensitive dan case insensitive.

Misalnya, [email protected] , [email protected] , dan [email protected] secara teoritis adalah alamat email yang berbeda. Sangat mudah untuk melihat bagaimana hal ini dapat menimbulkan masalah dan mengurangi pengalaman pengguna jika server email memilih untuk memperlakukan bagian lokal sebagai peka huruf besar/kecil. Oleh karena itu, banyak penyedia memperlakukan bagian lokal dari alamat email sebagai tidak peka huruf besar/kecil.

cara melihat suka di instagram

Adapun bagian domain, RFC 1035 menyatakan bahwa itu selalu tidak peka huruf besar-kecil. Ini berarti Anda dapat menulisnya dalam huruf kecil, huruf besar, atau kombinasi keduanya dan email Anda akan berakhir di alamat yang sama. Dalam penggunaan praktis, [email protected] , [email protected] , dan [email protected] adalah alamat email yang sama.

Dalam praktek

Meskipun alamat email hanya peka huruf besar-kecil sebagian, umumnya aman untuk menganggapnya tidak peka huruf besar-kecil. Semua penyedia utama, seperti Gmail, Yahoo Mail, Hotmail, dan lainnya, memperlakukan bagian lokal dari alamat email sebagai tidak peka huruf besar/kecil. Karena itu, Anda harus memeriksa aturan penyedia email yang ingin Anda gunakan untuk membuat email.

Menghubungkan ke poin sebelumnya, RFC 5321 yang disebutkan di atas merekomendasikan agar alamat email baru dibuat dengan huruf kecil hanya untuk menghindari potensi kebingungan dan masalah pengiriman.

Di sisi lain, jika teman atau kolega Anda memiliki alamat email dengan kombinasi karakter huruf besar dan kecil, disarankan untuk menulisnya seperti saat Anda mengirimi mereka email. Kegagalan untuk melakukannya dapat menyebabkan email tidak terkirim. Namun, ini bukan masalah dengan penyedia email utama seperti Gmail, Yahoo Mail, Hotmail, dan lainnya.

Selain itu, Gmail juga tidak peka terhadap titik-titik yang ditemukan di bagian lokal email ketika menyangkut identifikasi akun pengguna. Artinya jika akun [email protected] ada, Anda tidak akan bisa mendaftar [email protected] atau [email protected]

Penginternasionalan

Awalnya, alamat email hanya dapat didaftarkan menggunakan huruf alfabet Latin, angka, dan serangkaian karakter khusus ASCII. Namun, IETF (Internet Engineering Task Force) selanjutnya mengembangkan aturan dan standar untuk pencantuman karakter internasional.

RFC6530 adalah yang pertama memasukkan dan mengatur penggunaan karakter internasional. RFC6531 diperluas pada aturan dan standar. Selanjutnya, aturan dan standar diperbarui melalui RFC6532 dan RFC6533 .

Anda sekarang dapat mendaftarkan alamat email menggunakan berbagai abjad, karakter, dan skrip. Beberapa yang paling banyak digunakan termasuk karakter Latin dengan diakritik, alfabet Yunani, karakter Cina Tradisional, karakter Jepang (hiragana, katakana, dan kanji), alfabet Cyrillic, beberapa skrip India, serta berbagai lainnya.

Penyertaan dan kompatibilitas dengan alamat email internasional bervariasi dari satu penyedia ke penyedia lainnya. Bahkan beberapa penyedia terbesar tidak sepenuhnya kompatibel dengan alamat internasional. Misalnya, Google mengizinkan Anda mengirim email ke alamat internasional tetapi tidak mengizinkan Anda membuatnya. Outlook 2016 memiliki fungsi serupa.

Kesimpulan

Tidak seperti bagian nama domain, bagian lokal dari alamat email peka huruf besar/kecil. Karena itu, banyak penyedia email memilih untuk mengabaikan sensitivitas huruf besar/kecil dari bagian lokal untuk alasan praktis dan mendorong orang untuk membuat email dengan karakter huruf kecil saja.

Artikel Menarik

Pilihan Editor

Cara Mengedit Bio Instagram Anda
Cara Mengedit Bio Instagram Anda
Salah satu hal pertama yang akan dilihat siapa pun di profil Instagram Anda adalah bio Anda. Di sini, Anda dapat menulis informasi paling berharga tentang Anda, profil Anda, atau bisnis yang Anda kembangkan. Dan pengikut Anda dapat menemukan
Cara Mengetik Terbalik
Cara Mengetik Terbalik
Hasilkan angka dan huruf terbalik dan kirim teks terbalik atau posting status menggunakan alat online seperti TXTN atau dengan mempelajari karakter Unicode.
Apa Itu Pesan Suara dan Cara Mengaturnya
Apa Itu Pesan Suara dan Cara Mengaturnya
Pesan suara adalah pesan suara digital yang ditinggalkan penelepon di telepon rumah, Android, atau iPhone saat orang yang dihubungi tidak ada atau sedang sibuk dengan percakapan lain.
Apa itu File TEX?
Apa itu File TEX?
File TEX adalah file dokumen sumber LaTeX. Berikut lebih lanjut tentang file TEX termasuk cara membuka atau mengonversinya ke PDF, PNG, dll.
Cara Mengunduh dan Melihat Semua File Android Anda
Cara Mengunduh dan Melihat Semua File Android Anda
Salah satu dari banyak aspek keren Android adalah kenyataan bahwa Anda dapat mengakses semua aspek sistem operasi. Tidak seperti iOS, Anda dapat melihat semua file sistem dan memiliki akses ke setiap file dan folder di perangkat.
Cara mengubah warna latar belakang jendela Pidgin
Cara mengubah warna latar belakang jendela Pidgin
Pelajari cara mengubah warna latar belakang jendela Pidgin menggunakan file gtkrc.
Tuner Latar Belakang Desktop
Tuner Latar Belakang Desktop
Desktop Background Tuner adalah karya terbaru saya. Ini memungkinkan Anda untuk mengubah beberapa pengaturan registri tersembunyi dari fitur Latar Belakang Desktop di Windows 7 dan Windows 8. Versi 1.1 telah keluar, unduh sekarang. Dengan Desktop Background Tuner Anda akan dapat: Advertisment Menambahkan atau menghapus item ke kotak kombo 'Lokasi Gambar'. Saya akan menyebut mereka 'grup' untuk kesederhanaan,